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13 Advanced Editing  
Techniques

Lesson overview
In this lesson, you’ll learn how to do the following:

•	 Use motion stabilization to smooth out a shaky camera shot.

•	 Use single-point motion tracking to track one object in a shot to 
another object in a shot.

•	 Perform multipoint tracking using perspective corner-pinning.

•	 Use Imagineer Systems mocha for After Effects to track motion.

•	 Create a particle system.

•	 Use the Timewarp effect to create slow-motion video.

In previous lessons, you’ve used many of the essential 2D and 3D tools you 
need for motion graphics design. But Adobe After Effects CS4 also offers 
motion stabilization, motion tracking, advanced keying tools, distortion 
effects, the capability to retime footage using the Timewarp effect, sup-
port for high dynamic range (HDR) color images, network rendering, and 
much more. In this lesson, you will learn how to use the motion-stabiliza-
tion and motion-tracking features to stabilize a handheld camera shot and 
to track one object to another in an image so that their motion is synchro-
nized. Then, you will use corner-pinning to track an object with perspec-
tive. Finally, you will explore some of the high-end digital effects available 
in After Effects CS4: a particle system generator and the Timewarp effect.
This lesson will take approximately 2 hours to complete.
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After Eff ects CS4 provides advanced motion 
stabilization, motion tracking, high-end eff ects, and 
other features for the most demanding production 
environments.
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Getting started
This lesson includes multiple projects. Take a peek at all of them before beginning.

1	 Make sure the following files are in the AECS4_CIB/Lessons/Lesson 13 folder on  
your hard disk, or copy them from the Adobe After Effects CS4 Classroom in a 
Book DVD now.

•	 In the Assets folder: flowers.mov, Group_Approach[DV].mov, majorspoilers.
mov, metronome.mov, mocha_tracking.mov, multipoint_tracking.mov

•	 In the Sample_Movies folder: Lesson13_Multipoint.mov, Lesson_13_
Particles.mov, Lesson13_Stabilize.mov, Lesson13_Timewarp.mov, Lesson13_
Tracking.mov

2	 Open and play the sample movies in the Lesson13/Sample_Movies folder to see 
the projects you will create in this lesson. 

3	 When you’re done, quit QuickTime Player. You may delete these sample movies 
from your hard disk if you have limited storage space.

Using motion stabilization
If you shoot footage using a handheld camera, you will probably end up with shaky 
shots. Unless this look is intentional, you’ll want to stabilize your shots to eliminate 
unwanted motion.

To stabilize footage, After Effects first tracks the motion in the shot. It then shifts 
the position and rotation of each frame as necessary to remove the motion. When 
played back, the motion appears smooth because the layer itself moves incremen-
tally to offset the unwanted movement.

Setting up the project
As you start After Effects, restore the default application settings for After Effects.  
See “Restoring default preferences” on page 3.

1	 Press Ctrl+Alt+Shift (Windows) or Command+Option+Shift (Mac OS) while 
starting After Effects CS4 to restore default preferences. When asked whether 
you want to delete your preferences file, click OK.

2	 Click Close to close the Welcome window.

After Effects opens to display a new, untitled project.

3	 Choose File > Save As.

4	 In the Save As dialog box, navigate to the AECS4_CIB/Lessons/Lesson13/ 
Finished_Projects folder. 

5	 Name the project Lesson13_Stabilize.aep, and then click Save.

 Note:  You can view 
these movies all at once 
or, if you don’t plan to 
complete these 
exercises in one session, 
you can watch each 
sample movie just 
before you are ready to 
complete the associated 
exercise.
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Importing the footage
You need to import one footage item to start this project.

1	 Double-click an empty area of the Project panel to open the Import File dialog 
box.

2	 Navigate to the AECS4_CIB/Lessons/Lesson13/Assets folder. Select the 
flowers.mov file, and then click Open.

Creating the composition
Now, you will create the composition.

1	 Choose Composition > New Composition.

2	 In the Composition Settings dialog box, type Stabilize for the name.

3	 Make sure the Preset pop-up menu is set to NTSC DV. This automatically sets 
the width, height, pixel aspect ratio, and frame rate for the composition.

4	 In the Duration field, type 1000 to specify 10 seconds, which matches the length 
of the flowers.mov file, then click OK.

5	 Drag the flowers.mov item from the Project panel to the Timeline panel. The 
flowers image appears in the Composition panel.

6	 Drag the current-time indicator across the time ruler to manually preview the 
footage. This clip was shot with a handheld camera in the late afternoon. A slight 
breeze rustles the vegetation, and the camera moves unsteadily. 
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To stabilize this image, your first task is to identify two areas in the shot that are 
stationary within the context of the frame. These areas are called the feature regions. 
This figure shows two feature regions that will work for this project.

It is important to locate and size feature regions 
carefully. For the smoothest tracking, try to 
select areas that:

•	 Are visible for the entire shot.

•	 Have a contrasting color from the 
surrounding area.

•	 Have a distinct shape (at least within the 
search region).

•	 Have a consistent shape and color  
throughout the shot.

Positioning the track points
After Effects tracks motion by matching pixels from a selected area in a frame to 
pixels in each succeeding frame. You specify the area to track by using the track 
point. The track point contains the feature region as well as a search region and 
an attach point. After Effects displays the track point during tracking in the Layer 
panel.

You’ll open the Tracking Controls panel and apply track points to the clip.

1	 Press the Home key to make sure the current-time indicator is at the beginning 
of the time ruler. 

2	 Choose Window > Tracker to open the Tracker panel. The Tracker panel is 
where you specify your motion source and motion target layers, the type of 
tracking you want to use, and other tracking options.

3	 Click the Stabilize Motion button in the Tracker panel, and make sure that 
flowers.mov appears in the Motion Source pop-up menu. This tells After Effects 
that you want to stabilize the motion in the flowers layer. When you set these 
options, the Layer panel opens. In the Tracker panel, the Current Track pop-up 
menu shows Tracker 1 and the Track Type is set to Stabilize.

When you manually previewed the footage, you may have noticed that the camera 
not only moved left, right, up, and down, but also rotated slightly. So you need to 
stabilize the shot’s rotation as well as its position.

 Note:   The motion 
tracking will be based 
on the frame where the 
current-time indicator is 
positioned.
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4	 Select Position and Rotation in the Tracker panel. You should see two track 
point indicators in the Layer panel.

5	 Notice that Motion Target is the flowers.mov layer. When you stabilize a shot, 
the resulting data can be applied to the original layer, as specified here, or 
you can select another layer by clicking the Edit Target button. Leave it set to 
flowers.mov.

Now, you’re ready to set your track points.

6	 Using the Selection tool ( ), drag the Track Point 1 indicator (from the center) 
in the Layer panel to position it over the first feature region, which is the light 
green, closed flower bud below and to the left of the orange flower in the 
foreground.

7	  Drag the Track Point 2 indicator (from the center) to the second feature region, 
which is the light green leaf to the right of the orange foreground flower.



328 lesson 13 Advanced editing techniques

moving and resizing 
the  track points
In setting up motion tracking, it’s often necessary to refi ne your track point by 
adjusting the feature region, search region, and attach point. You can resize or 
move these items independently or in groups by dragging with the Selection tool. 
The pointer icon changes to refl ect one of many diff erent activities.

A B C D E

H I J

F G

Track point components (left) and Selection tool pointer icons (right): 
A. Search region B. Feature region C. Keyframe marker D. Attach point E. Moves 
search region F. Moves both regions G. Moves entire track point H. Moves attach 
point I. Moves entire track point J. Resizes region

• To turn feature region magnifi cation on or off , choose Magnify Feature When 
Dragging from the Tracker panel menu. A check mark appears next to the 
option when it’s on.

• To move the feature region, search region, and attach point together, drag with the 
Selection tool inside the track point area (avoiding the region edges and the attach 
point); the Move Track Point pointer ( ) appears.

• To move just the feature and search regions together, drag the edge of the 
feature region with the Selection tool; the Move Both Regions pointer ( ) 
appears.

• To move just the feature and search regions together, Alt-drag (Windows) or 
Option-drag (Mac OS) with the Selection tool inside the feature or search region; 
the Move Both Regions pointer ( ) appears.

• To move only the search region, using the Selection tool, drag the edge of the 
search region; the Move Search Region pointer ( ) appears.

• To move only the attach point, using the Selection tool, drag the attach point; 
the Move Attach Point pointer ( ) appears.

• To resize the feature or search region, drag a corner handle.

For more information about track points, see After Eff ects Help.
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Analyzing and applying stabilization
Now that the two track points are defined, After Effects can analyze the data and 
then apply the stabilization tracker.

1	 Click the Analyze Forward button ( ) in the 
Tracker panel. After Effects analyzes the motion 
stabilization for the duration of the clip.

2	 When the analysis is complete, click the Apply button. 

3	 In the Motion Tracker Apply Options dialog box, click OK to apply the stabili-
zation to the x and y dimensions.
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The motion-tracking data is added to the flowers layer in the Timeline panel, where 
you can see the track points, their properties, and their keyframes. You can also see 
the Anchor Point, Position, and Rotation keyframes that were applied to the layer. 
Keyframes are created at every frame, so 300 have been created for this 10-second 
shot. After Effects also opens the flowers image in the Composition panel again.

4	 Hide the properties for the flowers layer in the Timeline panel.

5	 Press the Home key to move the current-time indicator to the beginning of 
the timeline, and then watch a RAM preview of the stabilized shot. Press the 
spacebar to stop the playback when you’re ready.

Scaling the layer
You’ve stabilized the footage, but there’s still a problem. The tracking was applied to 
the Anchor Point and Rotation properties of the layer, but the entire layer is mov-
ing and rotating. This means you can see the edge of the shot and the empty space 
around it in some frames. An easy way to fix this is to scale the layer.

1	  Press the Home key to go to the beginning of the time ruler.

2	  With the flowers layer selected in the Timeline panel, press the S key to display 
its Scale property. 
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3	 Drag the current-time indicator across the time ruler until you find the frame 
where the layer displacement is the greatest (around 7:16).

4	  Increase the Scale values to 110, 110%. The clip fills the frame completely.

5	  Go to 2:16, where you can still see some of the empty area outside of the shot.

Because the tracking data is applied to the anchor point of the layer, you can reposi-
tion the entire layer without destabilizing it. 

6	 With the flowers layer selected in the Timeline panel, press P to reveal its 
Position property. The tracker added an initial Position keyframe to the layer. 
You don’t need it, so click the stopwatch icon ( ) to delete the keyframe.

7	 Change the Position values to 325, 375. 
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8	 Manually preview the clip once more to check for additional edge slips. You may 
need to scale the layer another percentage or two. When you’re done, go to 0:00.

9	 Watch another RAM preview. The shot should now look rock-steady, with the 
only movement being caused by the wind rustling the flowers. 

10		 Press the spacebar to stop playback when you’re done.

11		 Close the properties for the flowers layer in the Timeline panel, press the  
Home key to go to the beginning of the time ruler, and choose File > Save to  
save your work.

12	Choose File > Close Project.

As you have discovered, stabilizing a shot is not without its drawbacks. To compen-
sate for the movement or rotation data applied to the layer, you need to adjust the 
Scale and Position properties, which could ultimately degrade the footage. It is a fine 
line, but if you really need to use the shot in your production, this may be the best 
compromise.

Using single-point motion tracking
With the increase in the number of productions that incorporate digital elements 
into final shots, compositors need an easy way to synchronize computer-generated 
effects with film or video backgrounds. After Effects lets you do this with the 
capability to follow, or track, a defined area in the shot and apply that movement 
to other layers. These layers can contain text, effects, images, or other footage. The 
resulting visual effect precisely matches the original moving footage.

When you track motion in an After Effects composition that contains multiple lay-
ers, the default tracking type is Transform. This type of motion tracking tracks posi-
tion and/or rotation to apply to another layer. When tracking position, this option 
creates one track point and generates Position keyframes. When tracking rotation, 
this option creates two track points and produces Rotation keyframes.

In this exercise, you will track a shape layer to the weighted arm of a metronome.  
This will be especially challenging because the camera operator chose not to use a 
tripod.

Setting up the project
If you’ve just completed the first project, and After Effects is open, skip to step 3. 
Otherwise, restore the default application settings for After Effects. See “Restoring 
default preferences” on page 3. 

1	 Press Ctrl+Alt+Shift (Windows) or Command+Option+Shift (Mac OS) while 
starting After Effects CS4 to restore default preferences. When asked whether 
you want to delete your preferences file, click OK.

 Note:  The greater 
you scale the layer, the 
more the image quality 
will degrade, so keep 
the scale operation to a 
minimum.
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2	 Click Close to close the Welcome window.

After Effects opens to display a new, untitled project.

3	 Choose File > Save As.

4	 In the Save As dialog box, navigate to the AECS4_CIB/Lessons/Lesson13/ 
Finished_Projects folder. 

5	 Name the project Lesson13_Tracking.aep, and then click Save.

Importing the footage
You need to import one footage item to start this project.

1	 Double-click an empty area of the Project panel to open the Import File  
dialog box.

2	 Navigate to the AECS4_CIB/Lessons/Lesson13/Assets folder. Select the 
metronome.mov file, and then click Open.

Creating the composition
Now, you will create the composition.

1	 Choose Composition > New Composition.

2	 In the Composition Settings dialog box, type Tracking in the Composition 
Name field.

3	 Make sure the Preset pop-up menu is set to NTSC DV. This automatically sets 
the width, height, pixel aspect ratio, and frame rate for the composition.

4	 In the Duration field, type 800 to specify 8 seconds, which matches the length of 
the metronome.mov file, and then click OK.
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5	  Drag the metronome.mov item from the Project panel to the Timeline panel. 
The metronome image appears in the Composition panel.

6	 Drag the current-time indicator across the time ruler to manually preview the 
footage. You will track the metronome weight (the rhombus at the end of its 
arm) using the same tracking controls you used with the flowers. However, 
unlike motion stabilization, you need to place tracking regions around the area 
that you’ll track another layer to. 

Creating a shape layer
You’re going to apply a star to the end of the metronome. First, you need to create 
the star. You’ll use a shape layer.

1	 Press the Home key to make sure the current-time indicator is at the beginning 
of the time ruler, and then click in an empty area of the Timeline panel to 
deselect the layer.

2	 Select the Star tool ( ), hidden behind the Rectangle tool, in the Tools panel. 

3	 Click the Fill Color swatch, and select a light yellow such as RGB 220, 250, 90. 
Click the word Stroke, select None in the Stroke Options dialog box, and 
click OK.

4	 In the Composition panel, draw a small star.

5	 Use the Selection tool to position the star over the weighted end of the 
pendulum arm. 

6	 Make sure the anchor point of the star layer is in the center of the star shape. Use 
the Pan Behind tool to position the anchor point if necessary.
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Positioning the track point
With the star shape added to the Tracking composition, you are ready to position 
the track point.

1	 Select the metronome.mov layer in the Timeline panel.

2	 Choose Window > Tracker to open the Tracker panel, if it’s not already open.

3	 Click the Track Motion button in the Tracker panel. The Layer panel opens, with 
a Track Point 1 indicator in the center of the image. 

Notice the settings in the Tracker panel: The Motion Source is set to 
metronome.mov. The Current Track is Tracker 1, and the Motion Target is Shape 
Layer 1, because After Effects automatically sets the Motion Target to the layer 
immediately above the source layer.

Now, you’ll position your track point.

4	 Using the Selection tool ( ), move the Track Point 1 indicator (from the center) 
in the Layer panel over the weight of the metronome.

5	 Adjust the feature region (the inner box) within the weight. Because the 
pendulum moves left and right, enlarge the search region (the outer box) to 
encompass the area around the pendulum. 

 Note:  In this 
exercise, you want the 
star to move atop the 
metronome weight. 
However, if you wanted 
an object to move in 
relationship to the 
tracked area but not on 
top of it, you could 
reposition the attach 
point accordingly.
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Analyzing and applying tracking
Now that the search and feature regions are defined, you can apply the tracker.

1	 Click the Analyze Forward button ( ) in the Tracker panel. Watch the analysis 
to ensure the track point stays with the metronome weight. If it doesn’t, stop the 
analysis and reposition the feature region. (See the sidebar, “Checking for drift.”)

2	 When the analysis is complete, click the Apply button.

3	 In the Motion Tracker Apply Options dialog box, click OK to apply the tracking 
to the x and y dimensions. 

Checking for drift
As an image moves in a shot, the lighting, surrounding objects, and angle of the 
object can all change, making a once-distinct feature no longer identifiable at the 
subpixel level. It takes time to develop an eye for choosing a trackable feature. Even 
with careful planning and practice, you will often find that the feature region drifts 
away from the desired feature. Readjusting the feature and search regions, 
changing the tracking options, and trying again are a standard part of digital 
tracking. When you notice drifting occurring, try the following:

1	 Immediately stop the analysis by clicking the Stop button in the Tracker panel.

2	 Move the current-time indicator back to the last good tracked point. You can see 
this in the Layer panel.

3	 Reposition and/or resize the feature and search regions, being careful to 
not accidentally move the attach point. Moving the attach point will cause a 
noticeable jump in your tracked layer.

4	 Click the Analyze Forward button to resume tracking.

The motion-tracking data is added to the Timeline panel, where you can see that 
the track data is in the metronome layer, but the results are applied to the Position 
property of the Shape Layer 1 layer. This is another difference between tracking 
and stabilization: the resulting data is applied to a layer’s position, rather than to its 
anchor point.

4	 Watch a RAM preview. The star not only follows the pendulum; it moves with 
the camera’s movement.

5	 When you’re ready, press the spacebar to stop playback.

6	 Hide the properties for both layers in the Timeline panel, choose File > Save, and 
then choose File > Close Project.

Motion tracking an element onto background footage can be fun. As long as you 
have a stable feature to track, single-point motion tracking can be quite easy.

 Note:  The tracking 
analaysis may take quite 
a while. The larger the 
search and feature 
regions, the longer After 
Effects takes to analyze 
tracking.
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Using multipoint tracking
After Effects also offers two more advanced types of tracking that use multiple 
tracking points: parallel corner-pinning and perspective corner-pinning.

When you track using parallel corner-pinning, you simultaneously track three 
points in the source footage. After Effects calculates the position of a fourth point 
to keep the lines between the points parallel. When the movement of the points is 
applied to the target layer, the Corner Pin effect distorts the layer to simulate skew, 
scale, and rotation, but not perspective. Parallel lines remain parallel, and relative 
distances are preserved.

When you track using perspective corner-pinning, you simultaneously track four 
points in the source footage. When applied to the target footage, the Corner Pin 
effect uses the movement of the four points to distort the layer, simulating changes 
in perspective.

You’ll attach an animation to a computer monitor using perspective corner-pinning. 
If you haven’t already watched the sample movie for this exercise, do so now.  

Setting up the project
Start by launching After Effects and creating a new project.

1	 If it is not already open, start After Effects. Press Ctrl+Alt+Shift (Windows) or 
Command+Option+Shift (Mac OS) as you start it to restore default preferences. 
Click OK when asked whether you want to delete your preferences file, and click 
Close to close the Welcome window.

After Effects opens to display an empty, untitled project.

2	 Choose File > Save As.

3	 In the Save As dialog box, navigate to the AECS4_CIB/Lessons/Lesson13/
Finished_Projects folder.

4	 Name the project Lesson13_Multipoint.aep, and then click Save.

Importing the footage
You need to import two footage items for this exercise.

1	 Double-click an empty area of the Project panel to open the Import File  
dialog box.

2	 Navigate to the AECS4_CIB/Lessons /Lesson13/ Assets folder.

3	 Ctrl-click (Windows) or Command-click (Mac OS) to select the 
majorspoilers.mov and multipoint_tracking.mov files, and then click Open.
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Creating the composition
Now, you’ll create a new composition.

1	 Press Ctrl+N (Windows) or Command+N (Mac OS).

2	 In the Composition Settings dialog box, type Multipoint_Tracking in the 
Composition Name field.

3	 Make sure the Preset pop-up menu is set to NTSC DV. This automatically sets 
the width, height, pixel aspect ratio, and frame rate for the composition.

4	  Set the Duration to 7:05, which matches the length of the majorspoilers.mov 
file, and then click OK.

You will now add the footage items to the Timeline panel, one at a time.

5	 Drag the multipoint_tracking.mov item from the Project panel to the Timeline 
panel. It automatically appears in the Composition panel.

6	 Manually preview the footage, which is shaky because it was shot with a 
handheld camera. Because you’re positioning the majorspoilers.mov layer on 
the computer monitor, it will be fairly easy to place tracking markers on the 
flat plane.  By default, the tracker tracks by luminance, so you will use the areas 
around the screen that have high contrast differences for tracking.

7	 Press the Home key to return to the beginning of the time ruler.

8	 Drag the majorspoilers.mov footage item from the Project panel to the Timeline 
panel, placing it at the top of the layer stack.
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9	 To make it easier to see the underlying movie as you place the tracking points, 
turn off the Video switch for the majorspoilers.mov layer in the Timeline panel.

Positioning the track points
You’re ready to add the track points to the multipoint_tracking.mov layer.

1	 Select the multipoint_tracking.mov layer in the Timeline panel.

2	 Choose Window > Tracker to open the Tracker panel if it isn’t open.

3	 In the Tracker panel, choose multipoint_tracking.mov from the Motion Source 
menu, and then click Track Motion. The desk scene opens in the Layer panel, 
with a track point indicator in the center of the image. However, you will be 
tracking four points in order to attach the animated movie to the computer 
screen.

4	 Choose Perspective Corner Pin from the Track Type menu. Three more track 
point indicators appear in the Layer panel.

5	 Drag the track points to four different high-contrast areas of the image. The four 
corners of the computer screen provide excellent contrast. Use the following 
image as a guide. (Because the areas of high contrast are also where you want to 
attach the majorspoilers layer, you do not need to move the attach points.)

E Tip:  Refer to the 
sidebar, “Moving and 
resizing the track 
points,” in the first 
exercise of this lesson, 
for help moving the 
track point regions.

E Tip:  It may be 
helpful to zoom in 
when placing and 
adjusting the track 
points. Zoom out again 
when you have finished.
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Applying the multipoint tracker
You’re ready to analyze the data and apply the tracker.

1	 Click the Analyze Forward button ( ) in the Tracker panel. Then, when the 
analysis is complete, click the Apply button to calculate the tracking.

2	 Notice the results in the Timeline panel: you can see the Corner Pin and Position 
property keyframes for the majorspoilers layer and the track point data for the 
motion_tracking layer.

3	 Make the majorspoilers layer visible again, press the Home key to return to the 
beginning of the timeline, and watch a RAM preview to see the results of the 
tracker.

4	 When you’re done watching the preview, press the spacebar to stop playback.

If you don’t like the results, return to the Tracker panel, click the Reset button, and 
try again. With practice, you will become adept at identifying good feature regions.

5	 Press the Home key to go to 0:00, hide the layer properties to keep the Timeline 
panel neat, and choose File > Save to save your work.

6	 Choose File > Close Project.

 Note:  If the 
composition doesn’t 
appear in the 
Composition panel, 
click in the Timeline 
window to move the 
current-time indicator 
and refresh the display. 
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Mocha for After Effects
In most cases, you will get better and more accurate results using mocha from 
Imagineer Systems to track points in video. The mocha for After Effects tool is 
installed in the After Effects CS4 folder on your hard drive.

One advantage of mocha for After Effects is that you don’t have to accurately place 
tracking points to obtain a perfect track. Rather than using tracking points, mocha 
for After Effects uses a planar tracker, which attempts to track an object’s transla-
tion, rotation, and scaling data based on the movement of a user-defined plane. 
Planes provide more detail to the computer than is possible with single-point and 
multipoint tracking tools. 

When you work with mocha for After Effects, you need to identify planes in a clip 
that coincide with movement you want to track. Planes don’t have to be tabletops 
or walls. For example, if someone is waving goodbye, you can use their upper and 
lower limbs as two planes.

Mocha for After Effects uses two different spline technologies for tracking: X splines 
and Bezier splines. X splines may work better for tracking, especially with perspec-
tive motion, but Bezier splines work well, too, and are the industry standard.

After you track the planes, you can export the tracking data for use in After Effects. 

To learn more about mocha for After Effects, start the application and choose Help > 
Manual. 

We’ve saved some tracking data for the computer monitor in mocha for After 
Effects, so that you can apply it in After Effects if you’d like to. To apply the data,  
follow these steps:

1	 Create a new project in After Effects and import the majorspoilers.mov 
and mocha_tracking.mov files from the Lesson13/Assets folder. Create a 
new composition from the mocha_tracking.mov file, and then drag the 
majorspoilers.mov file to the top of the layer stack in the Timeline panel. 

2	 Open the mocha_data.txt file (in the Lesson 13/Optional_Mocha_Tutorial folder) 
in a text editor such as WordPad or TextEdit. (Don't use Notepad on Windows. 
It doesn't retain the mocha formatting, so After Effects doesn't recognize its 
content on the clipboard.) Choose Edit > Select All, and then Edit > Copy to 
copy all the data.

3	 Select the majorspoilers.mov layer in the Timeline panel, and choose Edit > 
Paste. All the data is applied to the layer.

4	 Watch a RAM preview to see the results.
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Creating a particle simulation
After Effects includes several effects that do an excellent job of creating particle 
simulations. Two of them—CC Particle Systems II and CC Particle World—are 
based on the same engine. The major difference between the two is that Particle 
World enables you to move the particles in 3D space, rather than a 2D layer.

In this exercise, you will learn how to use the CC Particle Systems II effect to create 
a supernova that could be used as the opening of a science program or as a motion 
background. If you haven’t already watched the sample movie for this exercise, do so 
now before continuing.  

Setting up the project
Start by launching After Effects and creating a new project.

1	 If it’s not already open, start After Effects. Press Ctrl+Alt+Shift (Windows) or 
Command+Option+Shift (Mac OS) as you start it to restore default preferences. 
Click OK when asked whether you want to delete your preferences file, and close 
the Welcome window.

After Effects opens to display an empty, untitled project.

2	 Choose File > Save As.

3	 In the Save As dialog box, navigate to the AECS4_CIB/Lessons/Lesson13/ 
Finished_Projects folder.

4	 Name the project Lesson13_Particles.aep, and then click Save.

Creating the composition
You do not need to import any footage items for this exercise. However, you do 
need to create the composition.

1	 Press Ctrl+N (Windows) or Command+N (Mac OS).

2	 In the Composition Settings dialog box, type Supernova in the Composition  
Name field.
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3	 Choose NTSC D1 from the Preset pop-up menu. This automatically sets the 
width, height, pixel aspect ratio, and frame rate for the composition.

4	 Set the Duration to 10:00, then click OK.

Creating a particle system
You will build the particle system from a solid layer, so you’ll create that next.

1	 Choose Layer > New > Solid to create a new solid layer.

2	 In the Solid Settings dialog box, type Particles in the Name box.

3	 Click Make Comp Size to make the layer the same size as the composition. Then, 
click OK.
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4	 With the Particles layer selected in the Timeline panel, choose Effect > 
Simulation > CC Particle Systems II.

5	 Go to 4:00 to see the particle system.

A large stream of yellow particles appears in the Composition panel.

Customizing the particle effect
You will turn this stream of particles into a supernova by customizing the settings in 
the Effect Controls panel.

1	 Expand the Physics property group in the Effect Controls panel. The Explosive 
Animation setting works fine for this project, but instead of the particles falling 
down, you want them to flow out in all directions, so change the Gravity value  
to 0.0.
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Understanding Particle 
Systems II properties
Particle systems have a unique vocabulary. Some of the key settings are explained 
here for your reference. They’re listed in the order in which they appear (top to 
bottom) in the Effect Controls panel.

Birth Rate Controls the number of particles generated per second. This is an 
arbitrary value and does not reflect the actual number of particles being generated. 
The higher the number, the more densely packed the particles become.

Longevity Determines how long the particles live.

Producer Position Controls the center point or origin of the particle system. The 
position is set based on the x, y coordinates. All particles emanate from this single 
point. You can control the size of the producer by making adjustments to the x and 
y radius settings. The higher these values, the larger the producer point will be. A 
high x value and a y value of zero (0) result in a line.

Velocity Controls the speed of particles. The higher the number, the faster the 
particles move.

Inherent Velocity % Determines how much of the velocity is passed along to the 
particles when the Producer Position is animated. A negative value causes the 
particles to move in the opposite direction.

Gravity Determines how fast particles fall. The higher the value, the faster the 
particles fall. A negative value causes particles to rise.

Resistance Simulates particles interacting with air or water, slowing over time.

Direction Determines which directions the particles flow. Use with the Direction 
Animation type.

Extra Introduces randomness into the movement of the particles.

Birth/Death Size Determines the size of the particles when they are created and 
when they expire. 

Opacity Map Controls opacity changes for the particle over its lifetime.

Color Map Use with the Birth and Death colors to shade the particles over time.
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2	 Hide the Physics property group and expand the Particle property group. Then, 
choose Faded Sphere from the Particle Type menu. 

Now the particles look intergalactic. Don’t stop there, though.

3	 Change the Death Size to 1.50 and increase the Size Variation to 100%. This 
allows the particles to change birth size randomly.

4	 Reduce the Max Opacity to 55%. This make the particles semi-transparent.

5	 Click the Birth Color swatch and change the color to RGB 255, 200, 50 to give 
the particles a yellow hue on birth, then click OK.

6	 Click the Death Color swatch and change the color to RGB 180, 180, 180 to give 
the particles a light gray hue as they fade out, then click OK.

7	 To keep the particles from staying onscreen too long, decrease the Longevity 
value to 0.8 seconds. 

 Note:  Even though 
they’re at the top of the 
Effect Controls panel, it 
is often easier to adjust 
the Longevity and Birth 
Rate settings after you 
have set the other 
particle properties.
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The Faded Sphere particle type softened the look, but the particle shapes are still  
too sharply defined. You will fix that by blurring the layer to blend the particles with  
one another. 

8	 Hide the CC Particle Systems II effect properties.

9	 Choose Effect > Blur & Sharpen > Fast Blur.

10		 In the Fast Blur area of the Effect Controls panel, increase the Blurriness value to 
10. Then, select Repeat Edge Pixels to keep the particles from being cropped at 
the edge of the frame.

Creating the sun
You will now create a bright halo of light that will go behind the particles.

1	 Go to 0:07.

2	 Press Ctrl+Y (Windows) or Command+Y (Mac OS) to create a new solid layer.

3	 In the Solid Settings dialog box do the following:

•	 Type Sun in the Name box.

•	 Click Make Comp Size to 
make the layer the same size 
as the composition.

•	 Click the color swatch to 
make the layer the same 
yellow as the Birth Color of 
the particles (255, 200, 50).

•	 Click OK to close the Solid 
Settings dialog box.
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4	 Drag the Sun layer below the Particles layer in the Timeline panel.

5	 Select the Ellipse tool ( ) in the Tools panel (behind the Rectangle tool ( ) or 
the Star tool ( ) and Shift-drag in the Composition panel to draw a circle with 
a radius of roughly 100 pixels, or one-fourth the width of the composition.

6	 Using the Selection tool ( ), drag the mask shape to the center of the 
Composition panel. 

7	 With the Sun layer selected in the Timeline panel, press the F key to reveal its 
Mask Feather property. Increase the Mask Feather amount to 100, 100 pixels.

8	 Press Alt+[ (Window) or Option+[ (Mac OS) to set the In point of the layer to 
the current time.

9	 Hide the properties for the Sun layer.
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Lighting the darkness
Since the sun is bright, it should illuminate the surrounding darkness.

1	 Make sure the current-time indicator is still at 0:07.

2	 Press Ctrl+Y (Windows) or Command+Y (Mac OS) to create a new solid layer.

3	 In the Solid Settings dialog box, name the layer Background, click the Make 
Comp Size button to make the layer the same size as the composition, and then 
click OK to create the layer. 

4	 In the Timeline panel, drag the Background layer to the bottom of the layer 
stack.

5	 With the Background layer selected in the Timeline panel, choose Effect >  
Generate > Ramp. 

The Ramp effect creates a color gradient, blending it with the original image. You 
can create linear or radial ramps, and vary the position and colors of the ramp over 
time. Use the Start Of Ramp and End Of Ramp settings to specify the start and end 
positions. Use the Ramp Scatter setting to disperse the ramp colors and eliminate 
banding.

6	 In the Ramp area of the Effect Controls panel, do the following:

•	 Change Start Of Ramp to 360, 240 and End Of Ramp to 360, 525.

•	 Choose Radial Ramp from the Ramp Shape menu.

•	 Click the Start Color swatch and set the start color to dark blue (RGB 0, 25, 
135).

•	 Set the End Color to black (RGB 0, 0, 0).

7	 Press Alt+[ (Windows) or Option+[ (Mac OS) to set the In point of the layer to 
the current time.
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Adding a lens flare
To tie all the elements together, add a lens flare to simulate an explosion.

1	 Press the Home key to move the current-time indicator to the beginning of the 
time ruler.

2	 Press Ctrl+Y (Windows) or 
Command+Y (Mac OS) to 
create a new solid layer.

3	 In the Solid Settings dialog box, 
name the layer Nova, click the 
Make Comp Size button to 
make the layer the same size as 
the composition, set the Color 
to black (RGB 0, 0, 0), and then 
click OK. The Nova layer should 
be at the top of the layer stack 
in the Timeline panel.

4	 With the Nova layer selected in the Timeline panel, choose Effect > Generate >  
Lens Flare.

5	 In the Lens Flare area of the Effect Controls panel, do the following:

•	 Change Flare Center to 360, 240.

•	 Choose 50–300mm Zoom from the Lens Type menu.

•	 Decrease Flare Brightness to 0%, and then click the Flare Brightness 
stopwatch icon ( ) to create an initial keyframe.
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6	 Go to 0:10.

7	 Increase the Flare Brightness to 240%.

8	 Go to 1:04 and decrease the Flare Brightness to 100%.

9	 With the Nova layer selected in the Timeline panel, press the U key to see the 
animated Lens Flare property.

10		 Right-click (Windows) or Control-click (Mac OS) the ending Flare Brightness 
keyframe and choose Keyframe Assistant > Easy Ease In.

11		 Right-click (Windows) or Control-click (Mac OS) the beginning Flare Brightness 
keyframe and choose Keyframe Assistant > Easy Ease Out.

Finally, you need to make the layers under the Nova layer visible in the composition.

12		 Press F2 to deselect all layers, and choose Columns > Modes from the Timeline 
panel menu. Then choose Screen from the Mode menu for the Nova layer.

13		 Watch a RAM preview. When you’re done, press the spacebar to stop the 
preview.

14	  Choose File > Save, and then choose File > Close Project.
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About high dynamic 
range (HDR) footage
After Effects CS4 also supports high dynamic range (HDR) color.

The dynamic range (ratio between dark and bright regions) in the physical world far 
exceeds the range of human vision and of images that are printed or displayed on a 
monitor. But while human eyes can adapt to very different brightness levels, most 
cameras and computer monitors can capture and reproduce only a limited dynamic 
range. Photographers, motion-picture artists, and others working with digital 
images must be selective about what’s important in a scene because they are 
working with a limited dynamic range.

HDR images open up a world of possibilities because they can represent a very wide 
dynamic range through the use of 32-bit floating-point numeric values. Floating-
point numeric representations allow the same number of bits to describe a much 
larger range of values than integer (fixed-point) values. HDR values can contain 
brightness levels, including objects as bright as a candle flame or the sun, that far 
exceed those in 8-bit-per-channel (bpc) or 16-bpc (non-floating-point) mode. Lower 
dynamic range 8-bpc and 16-bpc modes can represent RGB levels only from black 
to white, which represents an extremely small segment of the dynamic range in the 
real world.

Currently, HDR images are used mostly in motion pictures, special effects, 3D work, 
and some high-end photography. After Effects CS4 supports HDR images in a 
variety of ways. For example, you can create 32-bpc projects to work with HDR 
footage, and you can adjust the exposure, or the amount of light captured in an 
image, when working with HDR images in After Effects. For more information about 
support in After Effects for HDR images, see After Effects Help.

Retiming playback using the Timewarp effect
The Timewarp effect in After Effects CS4 gives you precise control over a wide range 
of parameters when changing the playback speed of a layer, including interpolation 
methods, motion blur, and source cropping to eliminate unwanted artifacts. The 
Timewarp effect works independently of the Frame Blend switch in the Timeline 
panel. 

In this exercise, you will use the Timewarp effect to change the speed of a clip for a 
dramatic slow-motion playback. If you haven’t already watched the sample movie 
for this exercise, do so now.  
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Setting up the project
Start by launching After Effects and creating a new project.

1	 If After Effects isn’t open, start it. Press Ctrl+Alt+Shift (Windows) or 
Command+Option+Shift (Mac OS) as you start it to restore default preferences. 
Click OK when asked whether you want to delete your preferences file, and close 
the Welcome window.

After Effects opens to display an empty, untitled project.

2	 Choose File > Save As.

3	 In the Save As dialog box, navigate to the AECS4_CIB/Lessons/Lesson13/ 
Finished_Projects folder.

4	 Name the project Lesson13_Timewarp.aep, and then click Save.

Importing the footage and creating the composition
You need to import one footage item for this exercise.

1	 Double-click an empty area of the Project panel to open the Import File  
dialog box.

2	 Navigate to the AECS4_CIB/Lessons/Lesson13/Assets folder on your hard disk, 
select the Group_Approach[DV].mov, and click Open. 

3	 Click OK in the Interpret Footage dialog box.

Now, create a new composition based on the footage item’s aspect ratio and 
duration.

4	 Drag the Group_Approach[DV].mov file onto the Create A New Composition 
button ( ) at the bottom of the Project panel. After Effects creates a new 
composition named for the source file and displays it in the Composition and 
Timeline panels.

5	 Choose File > Save to save your work.
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Using Timewarp
In the source footage, a group of young people approaches the camera at a steady 
pace. At around 2 seconds, the director would like the motion to begin to slow down 
to 10%, then ramp back up to full speed at 7:00.

1	 With the Group_Approach layer selected in the Timeline panel, choose Effect >  
Time > Timewarp.

2	 In the Timewarp area of the Effect Controls panel, choose Pixel Motion from 
the Method menu. This instructs Timewarp to create new frames by analyzing 
the pixel movement in nearby frames and creating motion vectors. Also, 
choose Speed from the Adjust Time By menu to control the time adjustment by 
percentage, rather than by a specific frame. 

3	 Go to 2:00.

4	 In the Effect Controls panel, set the Speed to 100 and click the stopwatch ( )  
to set a keyframe. This tells Timewarp to keep the speed of the clip at 100% until 
the 2-second mark.

5	 Go to 5:00 and change the Speed to 10. After Effects adds a keyframe.

6	 Go to 7:00 and set the Speed to 100. After Effects adds a keyframe.

7	 Press the Home key to go to the beginning of the time ruler, and then watch a 
RAM preview of the effect. 

You will see that the speed adjustments are rather abrupt, not the smooth, slow-
motion curve you would expect to see in a professional effect. This is because the 
keyframes are linear instead of curved. You’ll fix that next.

8	 Press the spacebar to stop the playback when you’re ready.

9	 With the Group_Approach[DV] layer selected in the Timeline panel, press the U 
key to see the animated Timewarp Speed property.

 Note:  Be patient. 
The RAM preview might 
take some time to 
calculate, but it will 
provide a more accurate 
playback than a 
spacebar preview.
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10		 Click the Graph Editor button ( ) in the Timeline panel to see the Graph Editor 
instead of the layer bars. Then, select the Speed property name for the Group_
Approach[DV] layer to see its graph.

11		 Click to select the first Speed keyframe (at 2:00), and then click the Easy Ease 
icon ( ) at the bottom of the Graph Editor. This adjusts the influence into and 
out of the keyframe to smooth out sudden changes.

12		 Repeat step 11 for the other two Speed keyframes in the motion graph, at 5:00  
and 7:00.

The motion graph is now smoother, but you can tweak it even more by dragging the 
Bezier handles. 

E Tip:  Close columns 
in the Timeline panel to 
see more icons in the 
Graph Editor. You can 
also apply an Easy Ease 
adjustment by pressing 
the F9 key.
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13		 Using the Bezier handles for the keyframes at 2:00 and 5:00, adjust the curve so 
that it resembles the following image. 

14		 Watch another RAM preview. Now, the slow-motion Timewarp effect looks 
professional. 

15		 Choose File > Save to save the project, and then choose File > Close Project.

You’ve now experimented with some of the advanced features in After Effects, 
including motion stabilization, motion tracking, particle systems, and the Timewarp 
effect. To render and export any or all of the projects you completed in this lesson, 
see Lesson 14, “Rendering and Outputting,” for instructions.

 Note:  If you need a 
refresher on using 
Bezier handles, see 
Lesson 7, “Working with 
Masks.”
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Review Questions
1	 Review uses Number List

Review questions
1	 What is motion stabilization and when do you need to use it?

2	 Why might drifting occur when you’re tracking an image?

3	 What is the birth rate in a particle effect?

4	 What does the Timewarp effect do?

Review answers
1	 Shooting footage using a handheld camera typically results in shaky shots. Unless this 

look is intentional, you will want to stabilize the shots to eliminate unwanted motion. 
Motion stabilization in After Effects works by analyzing the movement and rotation of 
the target layer, then applying the opposite values to the anchor point and rotation of 
that layer. When played back, the motion appears smooth because the layer itself moves 
incrementally to offset the unwanted motion.

2	 Drifting occurs when the feature region loses the feature that’s being tracked. As an 
image moves in a shot, the lighting, surrounding objects, and angle of the object can 
change, making a once-distinct feature unidentifiable at the subpixel level. Even with 
careful planning and practice, the feature region often drifts away from the desired 
feature. Readjusting the feature and search regions, changing the tracking options, and 
trying again are a standard part of digital tracking.

3	 The birth rate in a particle effect determines how often new particles are created.

4	 The Timewarp effect in After Effects CS4 gives you precise control over a wide range of 
parameters to change the playback speed of a layer, including interpolation methods, 
motion blur, and source cropping to eliminate unwanted artifacts.


