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1 Getting to Know 
the Workflow

Lesson overview
In this lesson you’ll learn how to do the following:

•	 Create a project and import footage.

•	 Create compositions and arrange layers.

•	 Navigate the Adobe After Effects interface.

•	 Use the Project, Composition, and Timeline panels.

•	 Apply basic keyframes and effects.

•	 Preview your work using standard and RAM previews.

•	 Customize the workspace.

•	 Adjust preferences related to the workspace.

•	 Find additional resources for using After Effects.

A basic After Effects workflow follows six steps: importing and organiz-
ing footage, creating compositions and arranging layers, adding effects, 
animating elements, previewing your work, and rendering and outputting 
the final composition so that it can be viewed by others. In this lesson, you 
will create a simple animated video using this workflow, and along the 
way, you’ll learn your way around the After Effects interface. This lesson 
will take about an hour to complete.
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Whether you use After Eff ects to animate a simple 
DVD title sequence or to create complex special 
eff ects, you generally follow the same basic workfl ow. 
The After Eff ects interface facilitates your work and 
adapts to each stage of production. 
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Getting started
First, you’ll preview the final movie to see what you’ll create in this lesson.

1	 Make sure the following files are in the AECS4_CIB/Lessons/Lesson01 folder on  
your hard disk, or copy them from the Adobe After Effects CS4 Classroom in a 
Book DVD now.

•	 In the Assets folder: bgwtext.psd, DJ.mov, gc_adobe_dj.mp3, kaleidoscope_
waveforms.mov, pulsating_radial_waves.mov 

•	 In the Sample_Movie folder: Lesson01.mov

2	 Open and play the Lesson01.mov sample movie to see what you will create in 
this lesson. When you are done, quit QuickTime Player. You may delete this 
sample movie from your hard disk if you have limited storage space.

Creating a project and importing footage
When you begin each lesson of this book, it’s a good idea to restore the default pref-
erences for After Effects. (See “Restoring default preferences” on page 3.) You can 
do this with a simple keyboard shortcut.

1	 Press Ctrl+Alt+Shift (Windows) or Option+Command+Shift (Mac OS) while 
starting After Effects to restore default preferences settings. When prompted, 
click OK to delete your preferences file.

2	 Click Close to close the Welcome window. 

After Effects opens to display an empty, untitled project.

An After Effects project is a single file that stores references to all the footage  
you use in that project. It also contains compositions, which are the individual  
containers used to combine footage, apply effects, and, ultimately, drive the output.
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About the After Effects workspace
After Effects offers a flexible, customizable workspace. The main window of the program 
is called the application window. Panels are organized in this window in an arrangement 
called a workspace. The default workspace contains groups of panels as well as panels 
that stand alone, as shown in the following figure. 
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A. Application window  B. Tools panel  C. Project panel  D. Composition panel   
E. Timeline panel  F. Time graph  G. Grouped panels (Info and Audio)  H. Preview panel   
I. Effects & Presets panel

You customize a workspace by dragging the panels into the configuration that best suits 
your working style. You can drag panels to new locations, move panels into or out of a 
group, place panels alongside each other, and undock a panel so that it floats in a new 
window above the application window. As you rearrange panels, the other panels resize 
automatically to fit the window. 

When you drag a panel by its tab to relocate it, the area where you can drop it—called a 
drop zone—becomes highlighted. The drop zone determines where and how the panel is 
inserted into the workspace. Dragging a panel to a drop zone results in one of two 
behaviors: docking or grouping.

If you drop a panel along the edge of another panel, group, or window, it will dock next 
to the existing group, resizing all groups to accommodate the new panel.

If you drop a panel in the middle of another panel or group, or along the tab area of a 
panel, it will be added to the existing group and be placed at the top of the stack. 
Grouping a panel does not resize other groups. 

You can also open a panel in a floating window. To do so, select the panel and then choose 
Undock Panel or Undock Frame from the panel menu. Or, drag the panel or group outside 
the application window.
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When you begin a project, often the first thing you’ll do is add footage to it.

3	 Choose File > Import > File.

4	 Navigate to the Assets folder in your AECS4_CIB/Lessons/Lesson01 folder.  
Shift-click to select the DJ.mov, gc_adobe_dj.mp3, kaleidoscope_waveforms.
mov, and pulsating_radial_waves.mov files (all the files except bgwtext.psd). 
Then click Open.

A footage item is the basic unit in an After Effects project. You can import many  
types of footage items, including moving-image files, still-image files, still-image 
sequences, audio files, layered files from Adobe Photoshop and Adobe Illustrator,  
other After Effects projects, and projects created in Adobe Premiere Pro. You can 
import footage items at any time.

As you import assets, After Effects reports its progress in the Info panel. 

Because one of the footage items for this project is a multilayer Photoshop file, you’ll 
import it separately as a composition.

5	 Double-click in the lower area of the Project panel to open the Import File  
dialog box. 

E Tip:  To quickly 
maximize a panel, 
position the pointer 
over it and press the 
` (accent grave) key (the 
unshifted character 
under the tilde, ~, on 
standard US keyboards). 
Press the key again to 
return the panel to its 
original size.

E Tip:  You can also 
double-click in the 
lower area of the Project 
panel to open the 
Import File dialog box, 
choose File > Import > 
Multiple Files to select 
files located in different 
folders, or drag and 
drop files from Explorer 
or the Finder. You can 
use Adobe Bridge to 
search for, manage, 
preview, and import 
footage. 



Adobe AFter Effects cs4 Classroom in a Book  13

6	 Navigate to the Lesson01/Assets folder again, and select the bgwtext.psd file. 
Choose Composition from the Import As menu, and then click Open.

After Effects opens an additional dialog box with options for the file you’re 
importing.

7	 In the Bgwtext.psd dialog box, choose Composition from the Import Kind menu 
to import the layered Photoshop file as a composition. Select Editable Layer 
Styles in the Layer Options area, and then click OK. The footage items appear in 
the Project panel.
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8	 In the Project panel, deselect all footage items and then click to select any of 
them. Notice that a thumbnail preview appears at the top of the Project panel. 
You can also see the file type and size, as well as other information about each 
item, in the Project panel columns.

When you import files, After Effects doesn’t copy the video and audio data itself into 
your project. Instead, each footage item in the Project panel contains a reference 
link to the source files. When After Effects needs to retrieve image or audio data, 
it reads it from the source file. This keeps the project file small, and it allows you to 
update source files in another application without modifying the project.

To save time and minimize the size and complexity of a project, import a footage 
item once and then use it multiple times in a composition. In some cases, you may 
need to import a source file more than once, such as if you want to use it at two dif-
ferent frame rates.

After you’ve imported footage, it’s a good time to save the project.

9	 Choose File > Save. In the Save As dialog box, navigate to the AECS4_CIB/
Lessons/Lesson01/Finished_Project folder. Name the project Lesson01_
Finished.aep, and then click Save.
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Creating a composition and arranging layers
The next step of the workflow is to create a composition. You create all animation, 
layering, and effects in a composition. An After Effects composition has both spatial 
dimensions and a temporal dimension (time).

Compositions include one or more layers, arranged in the Composition panel 
and in the Timeline panel. Any item that you add to a composition—such as a 
still image, moving-image file, audio file, light layer, camera layer, or even another 
composition—becomes a new layer. Simple projects may include only one composi-
tion, while elaborate projects may include several compositions to organize large 
amounts of footage or intricate effects sequences.

To create a composition, you will drag the footage items into the Timeline panel, 
and After Effects will create layers for them.

1	 In the Project panel, Ctrl-click (Windows) or Command-click (Mac OS) to 
select the bgwtext composition as well as the DJ, gc_adobe_dj, kaleidoscope_
waveforms, and pulsating_radial_waves footage items.

2	 Drag the selected footage items into the Timeline panel. The New Composition 
From Selection dialog box appears.
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After Effects bases the dimensions of the new composition on the selected footage. 
In this example, all of the footage is sized identically, so you can accept the default 
settings.

3	 Click OK to create the new composition. The footage items appear as layers 
in the Timeline panel, and After Effects displays the composition, named 
Bgwtext 2, in the Composition panel. 

When you add a footage item to a composition, the footage becomes the source for 
a new layer. A composition can have any number of layers, and you can also include 
a composition as a layer in another composition, which is called nesting.
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About layers
Layers are the components you use to build a composition. Any item that you add 
to a composition—such as a still image, moving-image file, audio file, light layer, 
camera layer, or even another composition—becomes a new layer. Without layers, a 
composition consists only of an empty frame.

Using layers, you can work with specific footage items in a composition without 
affecting any other footage. For example, you can move, rotate, and draw masks for 
one layer without disturbing any other layers in the composition, or you can use the 
same footage in more than one layer and use it differently in each instance. In 
general, the layer order in the Timeline panel corresponds to the stacking order in 
the Composition panel.

In this composition, there are five footage items and therefore five layers in the 
Timeline panel. Depending on the order in which the elements were selected when 
you imported them, your layer stack may differ from the one shown in the preceding 
figure. The layers need to be in a specific order as you add effects and animations, 
however, so you’ll rearrange them now.

4	 Click in an empty area of the Timeline 
panel to deselect the layers, and then 
drag Bgwtext to the bottom of the layer 
stack if it is not already there. Drag the 
other four layers so that they’re in the 
order shown in the figure.

From this point forward in the workflow, you should be thinking about layers, not 
footage items. You’ll change the column title accordingly.

5	 Click the Source Name column title 
in the Timeline panel to change it to 
Layer Name.

6	 Choose File > Save to save your project 
so far.

 Note:  You may need 
to click a blank area of 
the Timeline panel or 
press F2 to deselect 
layers before you can 
select an individual 
layer.
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About the Tools panel
As soon as you create a composition, the tools in the Tools panel in the upper-left 
corner of the After Effects application window become available. After Effects 
includes tools that enable you to modify elements of your composition. Some of 
these tools—the Selection tool and the Hand tool, for example—will be familiar to 
you if you use other Adobe applications, such as Photoshop. Others will be new. The 
following image identifies the tools in the Tools panel for your reference.

A B C D E F G H I J K L M

A. Selection  B. Hand  C. Zoom  
D. Rotation  E. Camera tools  
F. Pan Behind  G. Mask and 
Shape tools  H. Pen tools 
I. Type tools  J. Brush  K. Clone 
Stamp  L. Eraser  M. Puppet tools

When you hover the pointer over any button in the Tools panel, a tool tip identifies 
the tool and its keyboard shortcut. A small triangle in the lower-right corner of the 
button indicates that one or more additional tools are hidden behind it. Click and 
hold the button to display the hidden tools, and then select the tool you want to use.

Adding effects and modifying 
layer properties
Now that your composition is set up, you can start having fun—applying effects, 
making transformations, and adding animation. You can add any combination of 
effects and modify any of a layer’s properties, such as size, placement, and opacity. 
Using effects, you can alter a layer’s appearance or sound, and even generate visual 
elements from scratch. The easiest way to start is to apply any of the hundreds of 
effects included with After Effects. 

Preparing the layers
You’ll apply the effects to duplicates of selected layers—the DJ layer and the kalei-
doscope_waveforms layer. Working with duplicates lets you apply an effect to one 
layer and then use it in conjunction with the unmodified original.

1	 Select the first layer, DJ.mov, in the Timeline panel, and then choose Edit > 
Duplicate. A new layer with the same name appears at the top of the stack, so the 
first two layers are now both named DJ.mov.

 Note:  This exercise 
is just the tip of the 
iceberg. You will learn 
more about effects and 
animation presets in 
Lesson 2, “Creating a 
Basic Animation Using 
Effects and Presets,” and 
throughout the rest of 
this book.
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2	 Select the second layer and 
rename it to avoid confusion: 
Press Enter (Windows) or 
Return (Mac OS) to make 
the name editable, and type 
DJ_with_effects. Then press  
Enter or Return again to accept  
the new name.

3	 Select the kaleidoscope_
waveforms layer and make two 
duplicates. Then, rename the 
duplicates kaleidoscope_left 
and kaleidoscope_right.

4	 Drag if necessary to rearrange 
the layers in the Timeline panel 
so that they’re in the order 
shown.

Adding a Radial Blur effect
The Radial Blur effect creates blurs around a specific point in a layer, simulating the 
effects of a zooming or rotating camera. You’ll add a Radial Blur effect to the DJ.

1	 Select the DJ_with_effects layer in the Timeline panel. Notice that layer handles 
appear around the layer in the Composition panel.

E Tip:  Use the 
keyboard shortcut 
Ctrl+D (Windows) or 
Command+D (Mac OS) 
to duplicate the layers 
quickly.

 Note:  If you 
double-click a layer in 
the Timeline panel, it 
appears in the Layer 
panel. To return to the 
Composition panel, 
click the Composition 
tab.
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2	 In the Effects & Presets panel at the right side of the application window, type 
radial blur in the search box. 

After Effects searches for effects and presets that contain the letters you type, and 
displays the results interactively. Before you have finished typing, the Radial Blur 
effect, located in the Blur & Sharpen category, appears in the panel.

3	 Drag the Radial Blur effect onto the DJ_with_effects layer in the Timeline panel. 
After Effects applies the effect and automatically opens the Effect Controls panel 
in the upper-left area of the workspace.

Now you’ll customize the settings.
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4	 In the Effect Controls panel, choose Zoom from the Type menu.

5	 In the Composition panel, move the center point of the blur lower by dragging 
the center cross-hair ( ) down until it’s below the turntables. As you drag 
the cross-hair, the Center value updates in the Effect Controls panel. The 
left and right values are x and y coordinates, respectively. Center the blur at 
approximately 375, 450.

E Tip:  You can also 
type the x and y values 
directly into the 
coordinate fields in the 
Effect Controls panel, or 
you can position the 
pointer over the fields 
to see the double-arrow 
icon ( ) and then drag 
right or left to increase 
or decrease the values, 
respectively. Dragging 
to change values is 
called scrubbing.
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6	 Finally, increase the Amount to 200.

Adding an exposure effect
To punch up the brightness of this layer, you will apply the Exposure color- 
correction effect. This effect lets you make tonal adjustments to footage. It simulates 
the result of modifying the exposure setting (in f-stops) of the camera that captured 
the image.

1	 Locate the Exposure effect in the Effects & Presets panel by doing one of the 
following:

•	 Type Exposure in the search box.

•	 Click the triangle next to Color Correction to expand the list of color-
correction effects in alphabetical order.
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2	 Drag the Exposure effect in the Color Correction category onto the DJ_with_
effects layer name in the Timeline panel. After Effects adds the Exposure settings 
to the Effect Controls panel under the Radial Blur effect.

3	 In the Effect Controls panel, click the triangle next to the Radial Blur effect to 
collapse those settings so that you can see the Exposure settings more easily.

4	 For Master Exposure, enter 1.60. This will make everything brighter in the layer 
to simulate an overexposed image. 

E Tip:  Make sure to 
select the Exposure 
effect in the Color 
Correction category, not 
the Exposure animation 
preset in the Lights And 
Optical category.
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Transforming layer properties
The DJ looks smashing, so you can turn your attention to the kaleidoscope wave-
forms that are part of the background. You’ll reposition the copies you created 
earlier to create an edgy effect.

1	 Select the kaleidoscope_left layer (layer 5) in the Timeline panel.

2	 Click the triangle to the left of the layer number to expand the layer, and then 
expand the layer’s Transform properties: Anchor Point, Position, Scale, Rotation, 
and Opacity. 

3	 If you can’t see the properties, scroll down the Timeline panel using the scroll 
bar at the right side of the panel. Better yet, select the kaleidoscope_left layer 
name again and press P. This keyboard shortcut displays only the Position 
property, which is the only property you want to change for this exercise.

You’ll move this layer to the left about 200 pixels.

4	 Change the x coordinate for the Position property to 160. Leave the y coordinate 
at 243.

5	 Select the kaleidoscope_right layer (layer 6), and press P to display its Position 
property. You will move this layer to the right.

E Tip:  With any layer 
selected in the Timeline 
panel, you can display 
any single Transform 
property by pressing a 
keyboard shortcut:  
P displays Position 
A displays Anchor Point 
S displays Scale 
R displays Rotation 
T displays Opacity.
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6	 Change the x coordinate for the kaleidoscope_right Position property to 560. 
Leave the y coordinate at 243. Now you can see the three waveforms—left, 
center, and right—in the Composition panel, hanging like a beaded light curtain.

To contrast the left and right waveforms with the center waveform, you will reduce 
their opacity.

7	 Select the kaleidoscope_left layer in the Timeline panel and press T to reveal its 
Opacity property. Set it to 30%.

8	 Select the kaleidoscope_right layer in the Timeline panel, press T to reveal its 
Opacity property, and set it to 30%.

9	 Choose File > Save to save your work so far.

E Tip:  To change the 
Opacity property for 
multiple layers at once, 
select the layers, press 
T, and change the 
property for one of the 
selected layers. 
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Animating the composition
So far, you’ve started a project, created a composition, imported footage, and 
applied some effects. It all looks great, but how about some movement? You’ve 
applied only static effects.

In After Effects, you can change any combination of a layer’s properties over time 
using conventional keyframing, expressions, or keyframe assistants. You’ll explore 
many of these methods throughout the lessons of this book. For this exercise, you 
will animate the Position property of a text layer using keyframes, and then use an 
animation preset so that the letters appear to rain down on the screen. 

About the Timeline panel
Use the Timeline panel to animate layer properties and set In and Out points for a 
layer. (In and Out points are the points at which a layer begins and ends in the 
composition.) Many of the Timeline panel controls are organized in columns of 
related functions. By default, the Timeline panel contains a number of columns and 
controls, as shown in the following figure:

A B C

D E F

A. Composition name  B. Current time  C. Time graph/Graph Editor area  D. Audio/Video 
Switches column  E. Source Name/Layer Name column  F. Layer switches
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About the time graph
The time graph portion of the Timeline panel (the right side) contains a time ruler, 
markers to indicate specific times, and duration bars for the layers in your 
composition.

A

F G

D

E

B C

A. Time navigator start and end brackets  B. Work area start and end brackets   
C. Time ruler  D. Timeline panel menu  E. Time zoom slider F. Composition button   
G. Composition marker bin 

Before delving too deep into animation, it helps to understand at least some of 
these controls. The duration of a composition, a layer, or a footage item is repre-
sented visually in the time ruler. On the time ruler, the current-time indicator 
indicates the frame you are viewing or editing, and the frame appears in the 
Composition panel.

The work area start and end brackets indicate the part of the composition that will 
be rendered for previews or final output. When you work on a composition, you 
may want to render only part of a composition. Do this by specifying a part of the 
composition time ruler as a work area.

A composition’s current time appears in the upper-left corner of the Timeline panel. 
To move to a different time, drag the current-time indicator in the time ruler or click 
the current-time field in the Timeline panel or Composition panel, type a new time, 
and click OK.

For more information about the Timeline panel, see After Effects Help.

 Note:  When you 
click the Graph Editor 
button ( ) in the 
Timeline panel, the 
layer bars in the time 
ruler are replaced with 
the Graph Editor. You’ll 
learn more about  
the Graph Editor in 
Lesson 6, “Animating 
Layers.”
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Preparing the text composition
For this exercise, you’ll work with a separate composition—the one you imported 
from a layered Photoshop file.

1	 Click the Project tab to display the Project panel, and then double-click the 
bgwtext composition to open it as a composition in its own Timeline panel.

This composition is the layered Photoshop file you imported. Two layers, 
Background and Title Here, appear in the Timeline panel. The Title Here layer con-
tains placeholder text that was created in Photoshop. 

At the top of the Composition panel is the 
Composition Navigator bar, which displays the 
relationship between the main composition 
(Bgwtext 2) and the current composition 
(Bgwtext), which is nested within the main 
composition. 

You can nest multiple compositions within each other; the Composition Navigator 
bar displays the entire composition path. Arrows between the composition names 
indicate the direction in which pixel information flows.

Before you can replace the text, you need to make the layer editable. 

 Note:  You can 
quickly navigate within 
a composition network 
using the Composition 
Mini-Flowchart. To 
display the flowchart, 
tap the Shift key when a 
Composition, Timeline, 
or Layer panel is active.  
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2	 Select the Title Here layer (layer 1) in the Timeline panel and then choose 
Layer > Convert to Editable Text.

A T icon appears next to the layer name in the Timeline panel, indicating that it is 
now an editable text layer. The layer is also selected in the Composition panel, ready 
for you to edit.

Animating text with Position keyframes
You’ll start by replacing the placeholder text with real text. Then, you’ll animate it.

1	 Select the Horizontal Type tool ( ) in the Tools panel, and drag over the 
placeholder text in the Composition panel to select it. Then, type Substrate. 

2	 Select the Title Here layer in the Timeline panel again, and press P to display its 
Position property.

3	 Make sure you’re at the first frame of the animation by doing one of the 
following:

•	 Drag the current-time indicator all the way to the left of the time ruler,  
to 0:00.

•	 Press the Home key on your keyboard. 

 Note:  If you see a 
warning about missing 
fonts, just click OK.  

 Note:  After Effects 
offers robust character 
and paragraph 
formatting controls, but 
the default settings—
whatever typeface 
appeared when you 
typed—should be fine 
for this project. You’ll 
learn more about type 
in Lesson 3, “Animating 
Text.”
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About timecode and duration
The primary concept related to time is duration, or length. Each footage item, layer, 
and composition in a project has its own duration, which is reflected in the 
beginning and ending times displayed in the time rulers in the Composition, Layer, 
and Timeline panels.

The way you view and specify time in After Effects depends on the display style, or 
unit of measure, that you use to describe time. By default, After Effects displays time 
in Society of Motion Picture and Television Engineers (SMPTE) timecode: hours, 
minutes, seconds, and frames. Note that the figures are separated by semicolons in 
the After Effects interface, representing drop-frame timecode (which adjusts for the 
real-time frame rate), but this book uses a colon to represent non-drop-frame 
timecode.

To learn when and how to change to another system of time display, such as frames 
or feet and frames of film, see After Effects Help.

4	 Using the Selection tool ( ), drag the text layer down and off the bottom of the 
Composition panel, out of the viewing area. Press Shift after you start dragging 
to constrain the operation to the vertical axis.

5	 In the Timeline panel, click the stopwatch icon ( ) for the layer’s Position 
property to create a Position keyframe. An orange diamond appears in the 
Position bar for the layer in the time graph, indicating the new keyframe.



Adobe AFter Effects cs4 Classroom in a Book  31

Keyframes are used to create and control animation, effects, audio properties, and 
many other kinds of changes that occur over time. A keyframe marks the point in 
time where you specify a value, such as spatial position, opacity, or audio volume. 
Values between keyframes are interpolated. When you use keyframes to create a 
change over time, you must use at least two keyframes—one for the state at the 
beginning of the change, and one for the state at the end of the change.

6	 Go to 3:00 by doing one of the following:

•	 Drag the current-time indicator to the right in the time ruler so that it’s 
positioned at 3:00.

•	 Click the Current Time field in the Timeline panel or Composition panel, 
type 300 (for 3 seconds) in the Go To Time dialog box, and click OK.

Now you can drag the Substrate title to its final position, but since you dragged it off 
the screen in step 4, you’ll need to zoom out to grab it.

7	 With the Title Here layer still selected in the Timeline panel, select the Zoom  
tool ( ) and Alt-click (Windows) or Option-click (Mac OS) to zoom out so that 
you can see the text layer on the pasteboard of the Composition panel.

8	 Switch back to the Selection tool ( ) and drag the text layer up in the 
Composition panel, to the top quarter of the viewing area. Press Shift to 
constrain the drag operation to the vertical axis. Your final Position values 
should be approximately 359, 135.

E Tip:  Instead of 
zooming and dragging, 
you could also type the 
values into the text 
layer’s Position fields in 
the Timeline panel.
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After Effects automatically creates a second keyframe at this position.

9	 To zoom back in to the composition, choose Fit Up To 100% from the 
Magnification Ratio pop-up menu in the lower-left corner of the Composition 
panel.

The blue lines at the top, bottom, and sides of the Composition panel indicate 
title-safe and action-safe zones. Television sets enlarge a video image and allow 
some portion of its outer edges to be cut off by the edge of the screen. This is known 
as overscan. The amount of overscan is not consistent between television sets, so 
you should keep important parts of a video image, such as action or titles, within 
margins called safe zones. Keep your text inside the inner blue guides to ensure that 
it is in the title-safe zone, and keep important scene elements inside the outer blue 
guides to ensure that they are in the action-safe zone.

Even though this is a simple animation, you’ll learn good animation practices right 
away by adding ease-in controls using the Easy Ease feature. Easing into (and out of) 
animations keeps the motion from appearing to be too sudden or robotic.

10	Right-click (Windows) or Control-click (Mac OS) the Position keyframe at 3:00 
and choose Keyframe Assistant > Easy Ease In. As the text approaches its final 
position, it will ease to a smooth stop. The keyframe icon changes to an arrow.
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Adding an animation preset
So far, the text is moving onto the screen. After it arrives, you don’t want it to just sit 
there. Applying an animation preset will bring it to life.

1	 With the Title Here layer still selected in the Timeline panel, go to 2:10, the 
point at which the text is almost at its final position. Remember, you can go to 
the time by dragging the current-time indicator or by clicking the Current Time 
field in the Timeline panel or Composition panel.

2	 Click the Effects & Presets tab, and then type raining in the search box to 
quickly locate the Raining Characters animation presets.

3	 Drag the Raining Characters Out effect onto the word Substrate in the 
Composition panel to apply it to the text layer.

The Effect Controls panel opens so that you can customize the Echo effect, which is 
a component of the animation preset. The default settings are fine for this project.

4	 Choose File > Save to save your work so far.

Previewing your work
You’re probably eager to see the results of your work. After Effects provides several 
methods for previewing compositions, including standard preview, RAM preview, 
and manual preview. (For a list of manual preview controls, see After Effects Help.) 
All three methods are accessible through the Preview panel, which appears on the 
right side of the application window in the Standard workspace. 

Using standard preview
Standard preview (commonly called a spacebar preview) plays the composition from 
the current-time indicator to the end of the composition. Standard previews usually 
play more slowly than real time. They are useful when your composition is simple 
or in its early stages and doesn’t require additional memory for displaying complex 
animations, effects, 3D layers, cameras, and lights. You’ll use it now to preview the 
text animation.
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1	 In the Bgwtext Timeline panel, make sure 
that the Video switch ( ) is selected for 
the layers that you want to preview—the 
Title Here and Background layers, in this 
case.

2	 Press the Home key to go to the beginning of the time ruler.

3	 Do one of the following:

•	 Click the Play/Pause button ( ) in the 
Preview panel.

•	 Press the spacebar.

4	 To stop the standard preview, do one of the following:

•	 Click the Play/Pause button in the Preview panel.

•	 Press the spacebar.

Using RAM preview
RAM preview allocates enough RAM to play the preview (with audio) as fast as the 
system allows, up to the frame rate of the composition. Use RAM preview to play 
footage in the Timeline, Layer, or Footage panel. The number of frames played 
depends on the amount of RAM available to the application.

In the Timeline panel, RAM preview plays either the span of time you specify as the 
work area, or from the beginning of the time ruler. In the Layer and Footage panels, 
RAM preview plays only untrimmed footage. Before you preview, check which 
frames are designated as the work area.

You’ll preview the entire composition—the animated text plus graphic effects—
using a RAM preview.

1	 Click the Bgwtext 2 tab in the Timeline panel to bring it forward.

2	 Make sure that the Video switch ( ) is turned on for all of the layers in the 
composition, and press F2 to deselect all layers.

E Tip:  Click the 
pasteboard of the 
Composition panel if 
you want to hide the 
motion path for this 
preview.
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3	 Drag the work area brackets to the time span you want to preview: the work area 
start bracket should be at 0:00, and the work area end bracket should be at 10:00.

4	 Drag the current-time indicator to the beginning of the time ruler, or press the  
Home key.

5	 Click the RAM Preview button ( ) in the Preview panel or choose 
Composition > Preview > RAM Preview. 

A green progress bar indicates which 
frames are cached to RAM. When all of 
the frames in the work area are cached, the 
RAM preview plays back in real time. 

6	 To stop the RAM preview, press the spacebar.

The more detail and precision you want to see, the more RAM is required for RAM 
preview. You can control the amount of detail shown in either the standard or RAM 
preview by changing the resolution, magnification, and preview quality of your com-
position. You can also limit the number of layers previewed by turning off the  
Video switch for certain layers, or limit the number of frames previewed by adjust-
ing the composition’s work area.

7	 Choose File > Save to save your project.

About OpenGL previews
OpenGL provides high-quality previews that require less rendering time than other 
playback modes. It provides fast screen previewing of a composition without 
degrading resolution, which makes it a desirable preview option for many situa-
tions. When OpenGL does not support a feature, it simply creates a preview without 
using that feature. For example, if your layers contain shadows and your OpenGL 
hardware does not support shadows, the preview will not contain shadows. You can 
view information about your OpenGL card, if you have one, as well as enable or 
disable OpenGL, by choosing Edit > Preferences > Previews (Windows) or After 
Effects > Preferences > Previews (Mac OS). See After Effects Help for more informa-
tion about using OpenGL.

E Tip:  You can 
interrupt the caching 
process at any time by 
pressing the spacebar, 
and the RAM preview 
will play back only the 
frames that have been 
cached to that point.
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Optimizing performance in After Effects
How you configure After Effects and your computer determines how quickly After 
Effects renders projects. Complex compositions can require a large amount of 
memory to render, and the rendered movies can take a large amount of disk space 
to store. Refer to “Improve Performance” in After Effects Help for tips that can help 
you configure your system, After Effects preferences, and your projects for better 
performance.

Rendering and exporting your composition
When you’re finished with your masterpiece—as you are now—you can render 
and export it at the quality settings you choose and create movies in the formats 
that you specify. You will learn more about exporting compositions in subsequent 
lessons, especially in Lesson 14, “Rendering and Outputting.” If you’d like to skip 
ahead to Lesson 14 and render and export this project, you’re welcome to do so. 
Otherwise, you can just save it, and continue getting acquainted with the After 
Effects workspace.

Customizing the workspace
In the course of this project, you may have resized or repositioned some panels, or 
opened new ones. As you modify the workspace, After Effects saves those modifica-
tions, so the next time you open the project, the most recent version of the work-
space is used. However, you can choose to restore the original workspace at any 
time by choosing Window > Workspace > Reset “Standard.”

Alternatively, if you find yourself frequently using panels that aren’t part of the 
Standard workspace, or if you like to resize or group panels for different types of 
projects, you can save time by customizing the workspace to suit your needs. You 
can save any workspace configuration, or use any of the preset workspaces that 
come with After Effects. These predefined workspaces are suitable for different types 
of workflows, such as animation or effects work.
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Using predefined workspaces 
Take a minute to explore the predefined workspaces in After Effects.

1	 If you closed the Lesson01_Finished.aep project, open it—or any other 
project—to explore the workspaces.

2	 Choose Window > Workspace > Animation. After Effects opens the following 
panels at the right side of the application window: Info and Audio (grouped), 
Preview, Smoother, Wiggler, Motion Sketch, and Effects & Presets.

You can also change workspaces using the Workspace menu at the top of the 
window.

3	 Choose Paint from the Workspace menu at the top of the application 
window, next to the Search Help box. The Paint and Brushes panels open. The 
Composition panel is replaced by the Layer panel, for easy access to the tools 
and controls you need to paint in your compositions.
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Saving a custom workspace
You can save any workspace, at any time, as a custom workspace. Once saved, new 
and edited workspaces appear in the Window > Workspace submenu and in the 
Workspace menu at the top of the application window. If a project with a custom 
workspace is opened on a system other than the one on which it was created, After 
Effects looks for a workspace with a matching name. If After Effects finds a match 
(and the monitor configuration matches), it uses that workspace; if it can’t find a 
match (or the monitor configuration doesn’t match), it opens the project using the 
current local workspace.

1	 Close the Paint and Brushes panels by clicking the small x next to the panel 
names.

2	 Choose Window > Effects & Presets to open 
that panel, and then drag it into a group with 
the Preview panel. 

3	 Choose Window > Workspace > New Workspace. Enter a name for the 
workspace and click OK to save it, or click Cancel if you don’t want to save it. 

Controlling the brightness 
of the user interface 
You can brighten or darken the After Effects user interface. Changing the brightness 
preference affects panels, windows, and dialog boxes. 

1	 Choose Edit > Preferences > Appearance (Windows) or After Effects > 
Preferences > Appearance (Mac OS). 



Adobe AFter Effects cs4 Classroom in a Book  39

2	 Drag the Brightness slider to the left or right and notice how the screen changes.

 

3	 Click OK to save the new brightness setting or Cancel to leave your preferences 
unchanged. You can click Default to restore the default brightness setting.

Finding resources for using After Effects
For complete and up-to-date information about using After Effects panels, tools, 
and other application features, visit the Adobe website. To search for information 
in After Effects Help and support documents, as well as other websites relevant to 
After Effects users, simply enter a search term in the Search Help box in the upper-
right corner of the application window. You can narrow the results to view only 
Adobe Help and support documents, as well. 

If you plan to work in After Effects when you’re not connected to the Internet, 
download the most current PDF version of After Effects Help from www.adobe.
com/go/documentation.

For additional resources, such as tips and techniques and the latest product infor-
mation, check out the Adobe Community Help page at community.adobe.com/
help/main. 

 Note:  If After Effects 
detects that you are not 
connected to the 
Internet when you start 
the application, 
choosing Help > After 
Effects Help opens the 
Help HTML pages 
installed with After 
Effects. For more 
up-to-date information, 
view the Help files 
online or download the 
current PDF for 
reference.
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Checking for updates
Adobe periodically provides updates to software. You can easily obtain these 
updates through Adobe Updater, as long as you have an active Internet connection.

1	 In After Effects, choose Help > Updates. The Adobe Updater automatically 
checks for updates available for your Adobe software.

2	 In the Adobe Updater dialog box, select the updates you want to install, and then 
click Download And Install Updates to install them.

Congratulations. You’ve finished Lesson 1. Now that you’re acquainted with the 
After Effects workspace, you can continue to Lesson 2 to learn how to create and 
animate compositions using effects and preset animations, or you can proceed to 
another lesson in this book.

 Note:  To set your 
preferences for future 
updates, click 
Preferences. Select how 
often you want Adobe 
Updater to check for 
updates, for which 
applications, and 
whether to download 
them automatically. 
Click OK to accept the 
new settings.
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Review Questions
1	 Review uses Number List

Review questions
1	 What are the basic components of the After Effects workflow?

2	 What is a composition?

3	 Describe three ways to preview your work in After Effects.

4	 How can you customize the After Effects workspace?

Review answers
1	 Most After Effects workflows include these steps: import and organize footage, create 

compositions and arrange layers, add effects, animate elements, preview your work, and 
export the final composition.

2	 A composition is where you create all animation, layering, and effects. An After Effects 
composition has both spatial dimensions and time. Compositions include one or 
more layers—video, audio, still images—arranged in the Composition panel and in the 
Timeline panel. Simple projects may include only one composition, while elaborate 
projects may include several compositions to organize large amounts of footage or 
intricate effects sequences.

3	 You can manually preview your work in After Effects by moving the current-time 
indicator, or you can view either a standard or RAM preview. A standard preview 
plays your composition from the current-time indicator to the end of the composition, 
usually more slowly than real time. A RAM preview allocates enough RAM to play 
the preview (with audio) as fast as the system allows, up to the frame rate of the 
composition.

4	 You can customize the After Effects workspace by dragging the panels into the 
configuration that best suits your working style. You can drag panels to new locations, 
move panels into or out of groups, place panels alongside each other, and undock 
a panel so that it floats above the application window. As you rearrange panels, the 
other panels resize automatically to fit the application window. You can save custom 
workspaces by choosing Window > Workspace > New Workspace.
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2 Creating a Basic Animation 
Using Effects and Presets

Lesson overview
In this lesson you’ll learn how to do the following:

•	 Use Adobe Bridge to preview and import footage items.

•	 Work with the layers of an imported Adobe Illustrator file.

•	 Apply drop shadow and emboss effects.

•	 Apply a text animation preset.

•	 Adjust the time range of a text animation preset.

•	 Precompose layers.

•	 Apply a dissolve transition effect.

•	 Adjust the transparency of a layer.

•	 Render an animation for broadcast use. 

•	 Export an animation in SWF format for the web.

In this lesson, you will continue to learn the basics of the Adobe After 
Effects project workflow. You’ll learn new ways to accomplish basic tasks 
as you create a simple newscast identification graphic for a fictional TV 
station, Channel 5. You will animate the newscast ID so that it fades to 
become a watermark that can appear in the lower-right corner of the 
screen during other TV programs. Then, you’ll export the ID for use in 
broadcast output and as an SWF file for the web. This lesson will take 
about an hour to complete.


