
42

2 Creating a Basic Animation 
Using Effects and Presets

Lesson overview
In this lesson you’ll learn how to do the following:

•	 Use Adobe Bridge to preview and import footage items.

•	 Work with the layers of an imported Adobe Illustrator file.

•	 Apply drop shadow and emboss effects.

•	 Apply a text animation preset.

•	 Adjust the time range of a text animation preset.

•	 Precompose layers.

•	 Apply a dissolve transition effect.

•	 Adjust the transparency of a layer.

•	 Render an animation for broadcast use. 

•	 Export an animation in SWF format for the web.

In this lesson, you will continue to learn the basics of the Adobe After 
Effects project workflow. You’ll learn new ways to accomplish basic tasks 
as you create a simple newscast identification graphic for a fictional TV 
station, Channel 5. You will animate the newscast ID so that it fades to 
become a watermark that can appear in the lower-right corner of the 
screen during other TV programs. Then, you’ll export the ID for use in 
broadcast output and as an SWF file for the web. This lesson will take 
about an hour to complete.
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After Eff ects lets you hit the ground running with a 
variety of eff ects and animation presets. You can use 
them to create great-looking animations quickly and 
easily.
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Getting started
1	 Make sure the following files are in the AECS4_CIB/Lessons/Lesson02 folder on  

your hard disk, or copy them from the Adobe After Effects CS4 Classroom in a 
Book DVD now. 

•	 In the Assets folder: 5logo.ai, ggbridge.jpg

•	 In the Sample_Movie folder: Lesson02.mov

2	 Open and play the Lesson02.mov sample movie to see what you will create in 
this lesson. When you are done, quit QuickTime Player. You may delete this 
sample movie from your hard disk if you have limited storage space.

When you begin the lesson, restore the default application settings for After Effects.  
See “Restoring default preferences” on page 3.

3	 Press Ctrl+Alt+Shift (Windows) or Command+Option+Shift (Mac OS) while 
starting After Effects. When asked whether you want to delete your preferences 
file, click OK.

4	 Click Close to close the Welcome window.

After Effects opens to display a blank, untitled project.

5	 Choose File > Save As.

6	 In the Save As dialog box, navigate to the AECS4_CIB/Lessons/Lesson02/  
Finished_Project folder. 

7	 Name the project Lesson02_Finished.aep, and then click Save.

Importing footage using Adobe Bridge
In Lesson 1, you chose File > Import > File to import footage. However, After Effects 
also offers another, more powerful and flexible way to import footage for a composi-
tion: using Adobe Bridge. You can use Adobe Bridge to organize, browse, and locate 
the assets you need to create content for print, the web, television, DVD, film, and 
mobile devices. Adobe Bridge keeps native Adobe files (such as PSD and PDF files) 
as well as non-Adobe application files available for easy access. You can drag assets 
into your layouts, projects, and compositions as needed; preview assets; and even 
add metadata (file information) to assets to make files easier to locate. 

In this exercise, you will jump to Adobe Bridge to import the still-image file that will 
serve as the background of your composition.

1	 Choose File > Browse In Bridge. If you receive a message about adding an 
extension to Adobe Bridge, click OK.

Adobe Bridge opens, displaying a collection of panels, menus, and buttons.

E Tip:  To open Adobe 
Bridge directly, choose 
Adobe Bridge from the 
Start menu (Windows) 
or double-click the 
Adobe Bridge icon in 
the Applications /Adobe 
Bridge folder (Mac OS).
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2	 Click the Folders tab in the upper-left corner of Adobe Bridge.

3	 In the Folders panel, navigate to the AECS4_CIB/Lessons/Lesson02/Assets 
folder. Click the arrows to open nested folders. You can also double-click folder 
thumbnail icons in the Content panel.

The Content panel updates interactively. For example, when you select the Assets 
folder in the Folders panel, thumbnail previews of the folder’s contents appear in the 
Content panel. Adobe Bridge displays previews of image files such as those in PSD, 
TIFF, and JPEG formats, as well as Illustrator vector files, multipage Adobe PDF 
files, QuickTime movie files, and more.

4	 Drag the thumbnail slider at the bottom of the Adobe Bridge window to enlarge 
the thumbnail previews. 

 Note:  We’re using 
the Essentials 
workspace, which is the 
default workspace in 
Bridge. 

E Tip:  You can 
emphasize different 
information in Adobe 
Bridge by changing the 
workspace. To change 
the workspace, choose 
Window > Workspace > 
and then select a 
workspace. See 
Adobe Bridge Help to 
learn more about 
customizing Adobe 
Bridge.
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5	 Select the ggbridge.jpg file in the Content panel, and notice that it appears in the 
Preview panel, as well. Information about the file, including its creation date, bit 
depth, and file size, appears in the Metadata panel.

6	 Double-click the ggbridge.jpg thumbnail in the Content panel to place the file 
in your After Effects project. Alternatively, you can drag the thumbnail into the 
Project panel in After Effects.

Adobe Bridge returns you to After Effects when you place the file. You can close 
Adobe Bridge if you’d like. You won’t be using it again during this lesson.
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Creating the composition
Following the After Effects workflow you learned in Lesson 1, the next step to build-
ing the TV news ID is to create a new composition. In Lesson 1, you created the 
composition based on footage items that were selected in the Project panel. You can 
also create an empty composition, and then add your footage items to it.

1	 Create a new composition by doing one of the following:

•	 Click the Create A New Composition button ( ) at the bottom of the  
Project panel.

•	 Choose Composition > New Composition.

•	 Press Ctrl+N (Windows) or Command+N (Mac OS).

2	 In the Composition Settings dialog box, do the following:

•	 Name the composition Channel_5_News.

•	 Choose NTSC D1 from the Preset pop-up menu. NTSC D1 is the resolution 
for standard-definition television in the United States and some other 
countries. This preset automatically sets the width, height, pixel aspect ratio, 
and frame rate for the composition to NTSC standards.

•	 In the Duration field, type 300 to specify 3 seconds.

•	 Click OK.
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After Effects displays an empty composition named Channel_5_News in the 
Composition panel and in the Timeline panel. Now, you’ll add the background.

3	 Drag the ggbridge.jpg footage item from the Project panel to the Timeline panel 
to add it to the Channel_5_News composition.

4	 With the ggbridge layer selected in the Timeline panel, choose Layer > 
Transform > Fit To Comp to scale the background image to the dimensions of 
the composition.

E Tip:  The keyboard 
shortcut for fitting a 
layer to a composition is 
Ctrl+Alt+F (Windows) or 
Command+Option+F 
(Mac OS).
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Importing the foreground element
Your background is in place. The foreground object is a layered vector graphic that 
was created in Illustrator.

1	 Choose File > Import > File. 

2	 In the Import File dialog box, navigate to the 5logo.ai file in the AECS4_CIB/
Lessons/Lesson02/Assets folder. (The file appears as 5logo if you’ve hidden file 
extensions in Windows.)

3	 Select Composition from the 
Import As menu, and then click 
Open.

The Illustrator file is added to the 
Project panel as a composition named 
5logo. A folder named 5logo Layers 
also appears. This folder contains 
the three individual layers of the 
Illustrator file. Click the triangle to 
open the folder and see its contents if 
you’d like.

4	 Drag the 5logo composition file from the Project panel into the Timeline panel 
above the ggbridge layer.

You should now see both the background image and the logo in the Composition 
panel and in the Timeline panel.
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Working with imported Illustrator layers
The Channel 5 logo graphic was created in Illustrator; your job in After Effects is 
to add text and animate it for the station’s newscast. To work with the layers of the 
Illustrator file independently of the background footage, you’ll open the 5logo com-
position in its own Timeline and Composition panels.

1	 Double-click the 5logo composition in the Project panel. The composition opens 
in its own Timeline and Composition panels.

2	 Select the Horizontal Type tool ( ) in the Tools panel and click in the 
Composition panel to the left of the Channel 5 logo.

3	 Type NEWS, all capitals, and then select all of the text you just entered.
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4	 In the Character panel, select a sans serif typeface such as Myriad Pro and 
change the Font Size to 30 pixels. Leave all other options in the Character panel 
at their defaults.

5	 In the Paragraph panel, click the Right Align Text button ( ). Leave all other 
options in the Paragraph panel at their defaults. You’ll learn more about working 
with text in Lesson 3, “Animating Text.”

6	 Select the Selection tool ( ), and then drag the text in the Composition panel to 
position it as it appears in the following figure. Notice that when you switch to 
the Selection tool, the generic Text 1 layer name in the Timeline panel changes 
to NEWS, the text you typed. 

Applying effects to a layer
Now you will return to the main composition, Channel_5_News, and apply an effect 
to the 5logo layer. This will apply the effect to all of the layers nested in the 5logo 
composition.

 Note:  If the 
Character panel isn’t 
open, choose Window > 
Character.

 Note:  If the 
Paragraph panel isn’t 
open, choose Window > 
Paragraph.

E Tip:  Choose View > 
Show Grid to make the 
nonprinting grid visible 
to help you position 
objects. Choose View > 
Show Grid again to hide 
the grid when you’re 
done.
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Applying and controlling effects
You can apply or remove an effect at any time. Once you’ve applied effects to a 
layer, you can temporarily turn off one or all the effects in the layer to concentrate 
on another aspect of your composition. Effects that are turned off do not appear in 
the Composition panel and typically are not included when the layer is previewed 
or rendered.

By default, when you apply an effect to a layer, the effect is active for the duration of 
the layer. However, you can make an effect start and stop at specific times, or make 
the effect more or less intense over time. You’mjll learn more about creating 
animation using keyframes or expressions in Lesson 5, “Animating a Multimedia 
Presentation,” and Lesson 6, “Animating Layers.”

You can apply and edit effects on adjustment layers just as you do with other layers. 
However, when you apply an effect to an adjustment layer, the effect is applied to 
all layers below it in the Timeline panel.

Effects can also be saved, browsed, and applied as animation presets.

1	 Click the Channel_5_News tab in the Timeline panel, and select the 5logo layer. 
The effect you create next will be applied only to the logo elements, and not to 
the background image of the bridge.

2	 Choose Effect > Perspective > Drop Shadow. A soft-edged shadow appears 
behind the nested layers of the 5logo layer—the logo graphic, the rotated type, 
and the word news—in the Composition panel.
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You can customize the effect using the Effect Controls panel, which appears in front 
of the Project panel when you apply an effect.

3	 In the Effect Controls panel, reduce the drop shadow’s Distance to 3 and 
increase its Softness to 4. You can set these values by clicking the field and typing 
the number, or by dragging the orange, underlined value.

The drop shadow is nice, but the logo will stand out even more if you apply an 
emboss effect. You can use either the Effect menu or the Effects & Presets panel to 
locate and apply effects.

4	 Click the Effects & Presets tab to bring that panel forward. Then, click the 
triangle next to Stylize to expand the category.

5	 With the 5logo layer selected in the Timeline panel, drag the Color Emboss effect 
into the Composition panel. The Color Emboss effect sharpens the edges of 
objects in the layer without suppressing the original colors. The Effect Controls 
panel displays the Color Emboss effect below the Drop Shadow effect.

6	 Choose File > Save to save your work.
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Applying an animation preset
You’ve positioned the news logo and applied some effects to it. It’s time to add some 
animation. You will learn several ways to animate text in Lesson 3. For now, you’ll 
use a simple animation preset that will fade the word news onto the screen next to 
the Channel 5 logo. You’ll need to work in the 5logo composition so that you can 
apply the animation to only the NEWS text layer.

1	 Click the 5logo tab in the Timeline 
panel, and select the NEWS layer.

2	 Move the current-time indicator to 
1:10, which is when you want the text 
to start fading in.

3	 In the Effects & Presets panel, navigate to Animation Presets > Text > Blurs.

4	 Drag the Bullet Train animation preset onto the NEWS layer in the Timeline 
panel or over the word news in the Composition panel. Don’t worry about the 
text disappearing. You’re looking at the first frame of the animation, which 
happens to be blank.
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5	 Click in a blank area of the Timeline panel to deselect the NEWS layer, and then 
drag the current-time indicator to 2:10 to manually preview the text animation. 
The text appears, letter by letter, until the word news is fully onscreen at 2:10.

Precomposing layers for a new animation
The news ID is coming along nicely, and you’re probably eager to preview the 
complete animation. Before you do, however, you’ll add a dissolve to all of the logo 
elements except the word news. To do this, you need to precompose the other three 
layers of the 5logo composition: rotated type, 5 logo, and crop area. 

Precomposing is a way to nest layers within a composition. Precomposing moves the 
layers to a new composition. This new composition takes the place of the selected 
layers. When you want to change the order in which layer components are ren-
dered, precomposing is a quick way to create intermediate levels of nesting in an 
existing hierarchy.

1	 Shift-click to select the rotated type, 5 logo, and crop area layers in the 5logo 
Timeline panel.

2	 Choose Layer > Pre-compose.
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3	 In the Pre-compose dialog box, name the new composition Dissolve_logo.  
The Move All Attributes Into The New Composition option is selected by 
default. Then, click OK.

The three layers are replaced in the 5logo Timeline panel with a single layer, 
Dissolve_logo. This new, precomposed layer contains the three layers that you 
selected in step 1. You can apply the dissolve effect to it without affecting the NEWS 
text layer and its Bullet Train animation.

4	 Make sure the Dissolve_logo layer is selected in the Timeline panel and press the 
Home key to go to 0:00.

5	 In the Effects & Presets panel, 
open the Animation Presets > 
Transitions – Dissolves category,  
and then drag the Dissolve – 
Vapor animation preset onto the 
Dissolve_logo layer in the Timeline 
panel or in the Composition panel.

The Dissolve – Vapor animation 
preset includes three components—a 
master dissolve, a box blur, and a solid 
composite, all of which appear in the 
Effect Controls panel. The default set-
tings are fine for this project.

6	 Choose File > Save.

E Tip:  To locate the 
Dissolve – Vapor preset 
quickly, type vap in the 
search box in the Effects 
& Presets panel.
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Previewing the effects
It’s time to preview all of the effects together.

1	 Click the Channel_5_News tab in the Timeline panel to switch to the main 
composition. Press the Home key to make sure you’re at the beginning of the 
time ruler.

2	 Make sure the Video switch ( ) is selected for both layers of the Channel_5_
News Timeline panel.

3	 Click the Play button ( ) in the Preview panel or press the spacebar to watch the 
preview. Press the spacebar to stop playback at any time.

Adding transparency
Many TV stations display logos semi-transparently in the corner of the frame to 
emphasize the brand. You’ll reduce the opacity of the ID so that it can be used this 
way.

1	 Still in the Channel_5_News Timeline panel, go to 2:24.

2	 Select the 5logo layer and press T to display its Opacity property. By default, the 
Opacity is 100%—fully opaque. Click the stopwatch icon ( ) to set an Opacity 
keyframe at this location.

3	 Press the End key to go to the end of the time ruler (2:29), and change the 
Opacity to 40%. After Effects adds a keyframe.

Now, the logo appears, the word news flies in, and it all fades to 40% opacity. 
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4	 Watch a preview of your composition by clicking the Play button in the Preview 
panel, by pressing the spacebar, or by pressing 0 on your numeric keypad. Press 
the spacebar to stop playback when you’re done.

5	 Choose File > Save to save your project.

Rendering the composition
You’re ready to prepare your Channel 5 news ID for output. When you create out-
put, the layers of a composition and each layer’s masks, effects, and properties are 
rendered frame by frame into one or more output files or, in the case of a sequence, 
into a series of consecutive files.

Making a movie from your final composition can take a few minutes or many hours, 
depending on the composition’s frame size, quality, complexity, and compression 
method. When you place your composition in the render queue, it becomes a ren-
der item that uses the render settings assigned to it. While After Effects renders the 
item, you are unable to work in the program.

After Effects provides a variety of formats and compression types for rendering 
output; the format you choose depends on the medium from which you’ll play your 
final output or on the requirements of your hardware, such as a video-editing 
system. You will prepare this animation for two formats so that it can be used for 
broadcast purposes as well as on a website.

Exporting broadcast-quality output
You’ll start by rendering and exporting the composition so that it can be broadcast 
on television.

1	 Do one of the following to add the composition to the render queue:

•	 Select the Channel_5_News composition in the Project panel, and then 
choose Composition > Add to Render Queue. The Render Queue panel opens 
automatically.

•	 Choose Window > Render Queue to open the Render Queue panel, and 
then drag the Channel_5_News composition from the Project panel onto the 
Render Queue panel.

 Note:  For more 
about output formats 
and rendering, see 
Lesson 14, “Rendering 
and Outputting.”
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2	 Choose Maximize Frame from the Render Queue panel menu so that the panel 
fills the application window.

3	 Click the triangle to expand the Render Settings options. By default, After Effects 
renders compositions at the Best Quality and Full Resolution. The default 
settings are fine for this project.

4	 Click the triangle to expand the Output Module options. By default, After Effects 
uses lossless compression to encode the rendered composition into a movie file, 
which is fine for this project. However, you need to identify where to save the file.

5	 Click the underlined words Not Yet Specified next to the Output To pop-up menu.

E Tip:  The keyboard 
shortcut for the 
Maximize Frame 
command is the accent 
grave (`) character, 
which shares a key with 
the tilde (~) character.
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6	 In the Output Movie To dialog box, accept the default movie name (Channel_5_
News), select the AECS4_CIB/Lessons/Lesson02/Finished_Project folder for the 
location, and then click Save.

7	 Back in the Render Queue panel, click the Render button. 

After Effects displays a progress bar in the Render Queue panel as it encodes the file, 
and issues an audio alert when all items in the Render Queue have been rendered 
and encoded.

8	 When the movie is complete, choose Restore Frame Size from the Render Queue 
panel menu to restore your workspace.

Exporting a composition for the web
The production manager at Channel 5 wants to use this news ID on the station’s 
website, as well. For that purpose, you need to render and export the composition 
in SWF format. The SWF format is a widely used vector graphics and animation 
format for the web. It is a compact, binary format that can contain audio and vector 
objects. Web browsers with the Flash Player plug-in can play SWF files. 

Before exporting to SWF, you need to adjust the composition a bit for online 
display.

1	 Select the Channel_5_News composition in the Project panel, and then choose 
Composition > Composition Settings.
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2	 In the Basic tab of the Composition Settings dialog box, choose Web Video, 
320 x 240 from the Preset menu, and then click OK.

After Effects applies the new web-appropriate resolution—320 x 240 pixels—to the 
composition. As a result, both the background and 5logo layers are about twice as 
big as the composition, which is now smaller, has a different aspect ratio, and has a 
different frame rate (15 fps). So you need to reposition and resize the layers for the 
new output medium, including centering the logo in the composition.

3	 Open the Channel_5_News Timeline panel, select the ggbridge layer, and press 
Ctrl+Alt+F (Windows) or Command+Option+F (Mac OS) to fit the layer to the 
composition size.

4	 Go to 2:12, which is when the logo starts to fade in at the new frame rate.

5	 Select the 5logo layer in the Timeline panel, and then press P to reveal its 
Position property.

6	 Change the Position values to -4.4, -26.1 to center the logo in the composition.

Now, you’re ready to render and export the composition to SWF format.
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7	 With the Channel_5_News composition selected in the Project panel, choose 
File > Export > Adobe Flash Player (SWF).

8	 In the Save File As dialog box, accept the default filename (Channel_5_News.
swf), select the AECS4_CIB/Lessons/Lesson02/Finished_Project folder for the 
location, and then click Save.

9	 In the SWF Settings dialog box, select Medium from the JPEG Quality menu. 
This setting preserves image quality nicely but also reduces the file size 
somewhat. Leave all other settings at their defaults, and then click OK.

After Effects displays a progress bar as it renders the file and exports it to SWF 
format. It also saves a report in HTML to the same folder as the SWF file.

10		 Choose File > Save to save the final file.

11		 In Explorer (Windows) or the Finder (Mac OS), navigate to the AECS4_CIB/ 
Lessons/Lesson02/Finished_Project folder.

12		 Double-click the HTML file to open it in your default web browser, and preview 
the SWF file by clicking the link on the page. This Flash animation could be used 
as part of a splash screen on the TV station’s website, or as part of an ad, for 
example.

Congratulations. You’ve created a broadcast news show ID and watermark.

 Note:  SWF files can 
be played directly by 
Flash Player. The Flash 
Video (FLV) command 
in the Export submenu 
saves video content so 
that it can be published 
online, but it must be 
embedded in a SWF file 
to be played by Flash 
Player.

 Note:  After Effects 
exports text layers to 
SWF as vector graphics. 
Some layer types and 
layer switches are not 
supported, such as 3D 
Layers, 3D Cameras, and 
3D Lights. Nested layers 
are rasterized. For more 
on SWF export, see 
After Effects Help.
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Review Questions
1	 Review uses Number List

Review questions
1	 How do you use Adobe Bridge to preview and import files? 

2	 What is precomposing? 

3	 How do you customize an effect?

4	 How do you modify the transparency of a layer in a composition?

Review answers
1	 Choose File > Browse In Bridge to jump from After Effects to Adobe Bridge, where you 

can search for and preview image assets. When you locate the asset you want to use in 
an After Effects project, double-click it or drag it to the Project panel.

2	 Precomposing is a way to nest layers within a composition. Precomposing moves the 
layers to a new composition, which takes the place of the selected layers. When you 
want to change the order in which layer components are rendered, precomposing is a 
quick way to create intermediate levels of nesting in an existing hierarchy.

3	 After you apply an effect to a layer in a composition, you can customize its properties in 
the Effect Controls panel. This panel opens automatically when you apply the effect,  
or you can open it at any time by selecting the layer with the effect and choosing 
Window > Effect Controls. 

4	 To modify the transparency of a layer, reduce its opacity. Select the layer  
in the Timeline panel, press T to reveal its Opacity property, and enter a value lower 
than 100%.


